Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted 2 months ago. Dec 15, 2024 - 00:55 EST
Scheduled
We will be undergoing scheduled maintenance during this time. Users will experience issues or see an error message while logging in or managing files during this time.
Posted 2 months ago. Dec 11, 2024 - 14:26 EST
This scheduled maintenance affected: Sync Software Clients (Windows Desktop, Android Mobile Client, Mac Desktop, iOS Mobile Client), Platform Services (Links, Admin tools (Pro Teams), Events, Shared Folders), and Control Panel.