Emergency Upstream Maintenance

Incident Report for Sync

Resolved

This incident has been resolved.
Posted May 05, 2026 - 17:10 EDT

Monitoring

One of our upstream providers will be performing emergency maintenance to address a network degradation impacting a subset of our users. Affected users may experience intermittent connection issues n this period.

We will continue to monitor and provide updates.
Posted May 05, 2026 - 13:14 EDT
This incident affected: Sync Software Clients (Windows Desktop, Android Mobile Client, Mac Desktop, iOS Mobile Client), Platform Services (Links, Admin tools (Pro Teams), Events, Shared Folders), and Control Panel.