Scheduled Maintenance

Incident Report for Sync

Resolved

This incident has been resolved.
Posted Jun 26, 2025 - 21:57 EDT

Update

Billing and subscription management has been restored. A small number of users may continue to experience issues - we are continuing to work to resolve these as quickly as possible.
Posted Jun 26, 2025 - 18:28 EDT

Monitoring

A fix has been implemented and we are monitoring the results. Billing and subscription management features continue to be impacted.
Posted Jun 26, 2025 - 15:18 EDT

Identified

We are working to resolve an outage in our systems, the cause has been identified and a fix is underway
Posted Jun 26, 2025 - 15:03 EDT

Investigating

We will be undergoing scheduled maintenance during this time. Users will experience elevated issues or see an error message while logging in or managing files during this time.
Posted Jun 26, 2025 - 09:42 EDT
This incident affected: Sync Software Clients (Windows Desktop, Android Mobile Client, Mac Desktop, iOS Mobile Client), Platform Services (Links, Admin tools (Pro Teams), Events, Shared Folders), and Control Panel.