Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted 10 days ago. Mar 26, 2025 - 02:00 EDT
Scheduled
Our upstream provider will be performing routine maintenance. We will be monitoring the situation and do not anticipate any service interruptions during this time.
Posted 14 days ago. Mar 22, 2025 - 14:01 EDT
This scheduled maintenance affected: Sync Software Clients (Windows Desktop, Android Mobile Client, Mac Desktop, iOS Mobile Client), Platform Services (Links, Admin tools (Pro Teams), Events, Shared Folders), and Control Panel.